Rogers Communications Down
Incident Report for Premier Locates Inc
Resolved
This incident has been resolved.
Posted Jul 09, 2022 - 17:02 EDT
Identified
Rogers Communications is experiencing an issue with their networks. Calls to and from Rogers subscribers may experience issues. You may experience higher than normal wait times while calling today. Please see Rogers for updates
Posted Jul 08, 2022 - 08:53 EDT